summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSylvain Munaut <tnt@246tNt.com>2011-09-02 22:18:24 +0200
committerSylvain Munaut <tnt@246tNt.com>2011-09-02 22:21:09 +0200
commitfe28dedd4c25b5f0f3df39d5e33ce3639574406c (patch)
tree7e4bad715499c7d51e5e5ed3cc886c738514f10a /configure.ac
parentbf9d25039c770867d2761ef11ef700e21addffba (diff)
core/serial: Add utilities to deal with serial ports
Signed-off-by: Sylvain Munaut <tnt@246tNt.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ae811e1a..52ab850f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -99,6 +99,14 @@ AC_ARG_ENABLE(msgfile,
[enable_msgfile=$enableval], [enable_msgfile="yes"])
AM_CONDITIONAL(ENABLE_MSGFILE, test x"$enable_msgfile" = x"yes")
+AC_ARG_ENABLE(serial,
+ [AS_HELP_STRING(
+ [--disable-serial],
+ [Disable support for the serial helpers],
+ )],
+ [enable_serial=$enableval], [enable_serial="yes"])
+AM_CONDITIONAL(ENABLE_SERIAL, test x"$enable_serial" = x"yes")
+
AC_ARG_ENABLE(utilities,
[AS_HELP_STRING(
[--disable-utilities],
@@ -119,6 +127,7 @@ then
AM_CONDITIONAL(ENABLE_TESTS, false)
AM_CONDITIONAL(ENABLE_PLUGIN, false)
AM_CONDITIONAL(ENABLE_MSGFILE, false)
+ AM_CONDITIONAL(ENABLE_SERIAL, false)
AM_CONDITIONAL(ENABLE_VTY, false)
AM_CONDITIONAL(ENABLE_TALLOC, false)
AM_CONDITIONAL(ENABLE_UTILITIES, false)