summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@flameeyes.eu>2012-06-29 13:01:18 -0700
committerHarald Welte <laforge@gnumonks.org>2012-06-30 22:01:42 +0200
commitea0e1eca2bc32b531242a3b0a3c471e492a6f493 (patch)
tree26b6bda92e3da6d056db3986c6ce942553e1ecfd /configure.ac
parent327009e4206dc5c50bcad21658872f547d3b6f25 (diff)
build: simplify test handling and speed up build.
Instead of using a ./configure parameter to decide whehter to build tests or not, use the check_PROGRAMS variable so that the tests are only built when running `make check`. To avoid slowing down the test phase itself, collapse the declaration of the test targets in the tests/Makefile.am file, this way they can be built and linked in parallel before the testsuite is executed. Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 0 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 484a7ddf..7c62f8f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,14 +59,6 @@ AC_ARG_ENABLE(plugin,
[enable_plugin=$enableval], [enable_plugin="yes"])
AM_CONDITIONAL(ENABLE_PLUGIN, test x"$enable_plugin" = x"yes")
-AC_ARG_ENABLE(tests,
- [AS_HELP_STRING(
- [--disable-tests],
- [Disable building test programs]
- )],
- [enable_tests=$enableval], [enable_tests="yes"])
-AM_CONDITIONAL(ENABLE_TESTS, test x"$enable_tests" = x"yes")
-
AC_ARG_ENABLE(vty,
[AS_HELP_STRING(
[--disable-vty],
@@ -130,7 +122,6 @@ AC_ARG_ENABLE(embedded,
if test x"$embedded" = x"yes"
then
AC_DEFINE([EMBEDDED],[1],[Select building for embedded use])
- AM_CONDITIONAL(ENABLE_TESTS, false)
AM_CONDITIONAL(ENABLE_PLUGIN, false)
AM_CONDITIONAL(ENABLE_MSGFILE, false)
AM_CONDITIONAL(ENABLE_SERIAL, false)
@@ -163,17 +154,6 @@ AC_OUTPUT(
src/gsm/Makefile
src/gb/Makefile
tests/Makefile
- tests/timer/Makefile
- tests/sms/Makefile
- tests/msgfile/Makefile
- tests/ussd/Makefile
- tests/smscb/Makefile
- tests/bits/Makefile
- tests/a5/Makefile
- tests/auth/Makefile
- tests/conv/Makefile
- tests/lapd/Makefile
- tests/gsm0808/Makefile
utils/Makefile
Doxyfile.core
Doxyfile.gsm