summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2012-09-08 22:18:43 +0200
committerHarald Welte <laforge@gnumonks.org>2012-09-08 22:18:43 +0200
commite3a10b66a4eaea7c7d06707be1ca18bb28dc2cbe (patch)
treebfdd32694887c1d84870b8298a5caa903249b2cc /configure.ac
parentaef917593ac9cce155252f612299c1d626775c1c (diff)
libosmogb: make build conditional, disable in embedded build
when we build for osmocom-bb cross-compilation, we don't have sockets nor netinet/in.h and thus NS/BSSGP make no sense...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ca98fc2c..f119c90d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,6 +137,14 @@ AC_ARG_ENABLE(utilities,
[enable_utilities=$enableval], [enable_utilities="yes"])
AM_CONDITIONAL(ENABLE_UTILITIES, test x"$enable_utilities" = x"yes")
+AC_ARG_ENABLE(gb,
+ [AS_HELP_STRING(
+ [--disable-gb],
+ [Disable building Gb library],
+ )],
+ [enable_gb=$enableval], [enable_gb="yes"])
+AM_CONDITIONAL(ENABLE_GB, test x"$enable_gb" = x"yes")
+
AC_ARG_ENABLE(embedded,
[AS_HELP_STRING(
[--enable-embedded],
@@ -152,6 +160,7 @@ then
AM_CONDITIONAL(ENABLE_VTY, false)
AM_CONDITIONAL(ENABLE_TALLOC, false)
AM_CONDITIONAL(ENABLE_UTILITIES, false)
+ AM_CONDITIONAL(ENABLE_GB, false)
AC_DEFINE([PANIC_INFLOOP],[1],[Use infinite loop on panic rather than fprintf/abort])
fi