summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@osmocom.org>2019-12-15 19:13:26 +0100
committerHarald Welte <laforge@osmocom.org>2019-12-16 00:17:27 +0100
commitda432cdc35ddc3e2e1374f7fc46210b4a92e6f54 (patch)
tree2aea6b55f7d66bc517fbe4464de0b88b793fc521 /configure.ac
parent7d0fe2ae6f9892faac0fc4374573869e6edf325e (diff)
libosmocore libusb integration
Osmocom applications typically use libosmocore select.[ch] event loop code as their main event dispatch mechanism. When they want to deal with libusb in a non-blocking/asynchronous way, they need to integrate libusb into that select(). The new libosmousb is doing exactly that: Providing a shared utility library for Osmocom programs that wish to use libusb. This is useful for example in simtrace2 host utilitie as well as osmo-e1d. Change-Id: I656a1a38cbb5b1f3a9145d2869d3b4d0adefcae3 Closes: OS#4299
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 060d081e..e45ec9f1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -146,6 +146,19 @@ AS_IF([test "x$ENABLE_PCSC" = "xyes"], [
AM_CONDITIONAL(ENABLE_PCSC, test "x$ENABLE_PCSC" = "xyes")
AC_SUBST(ENABLE_PCSC)
+AC_ARG_ENABLE([libusb], [AS_HELP_STRING([--disable-libusb], [Build without libusb support])],
+ [
+ ENABLE_LIBUSB=$enableval
+ ],
+ [
+ ENABLE_LIBUSB="yes"
+ ])
+AS_IF([test "x$ENABLE_LIBUSB" = "xyes"], [
+ PKG_CHECK_MODULES(LIBUSB, libusb-1.0)
+])
+AM_CONDITIONAL(ENABLE_LIBUSB, test "x$ENABLE_LIBUSB" = "xyes")
+AC_SUBST(ENABLE_LIBUSB)
+
AC_ARG_ENABLE([gnutls], [AS_HELP_STRING([--disable-gnutls], [Do not use GnuTLS fallback for missing getrandom()])],
[ENABLE_GNUTLS=$enableval], [ENABLE_GNUTLS="yes"])
AM_CONDITIONAL(ENABLE_GNUTLS, test x"$ENABLE_GNUTLS" = x"yes")
@@ -398,12 +411,14 @@ AC_OUTPUT(
libosmogb.pc
libosmoctrl.pc
libosmosim.pc
+ libosmousb.pc
include/Makefile
src/Makefile
src/vty/Makefile
src/codec/Makefile
src/coding/Makefile
src/sim/Makefile
+ src/usb/Makefile
src/gsm/Makefile
src/gb/Makefile
src/ctrl/Makefile