summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNeels Hofmeyr <neels@hofmeyr.de>2016-11-15 17:31:14 +0100
committerHarald Welte <laforge@gnumonks.org>2016-11-16 16:40:44 +0000
commit96831049d926a6faf291a8ce29433e7718369b58 (patch)
tree9cd8368036421071dc4ca71e1d535da1832e3842 /configure.ac
parent6e363e7e31761f47d06d4074670d85693d03c038 (diff)
build: make check: disable sim_test when built with --disable-pcsc
Numerous issues caused sim_test to be attempted even though libosmosim was not built: In configure.ac, the ENABLE_PCSC variable lacked an AC_SUBST() to be exported. Furthermore in configure.ac, no value 'yes'/'no' was assigned to the ENABLE_PCSC variable, only to the enable_pcsc value. In testsuite.at, encapsulating the sim_test in 'if ENABLE_PCSC' seems to have no effect, regardless (not even when using a variable that should be defined accurately). So fix with these steps, similarly to how we do it in openbsc: In AC_ARG_ENABLE, directly use 'ENABLE_PCSC' to assign 'yes'/'no'. Export the same using AC_SUBST(). Add tests/atlocal.in to translate ENABLE_PCSC to enable_sim_test (also add atlocal to AC_OUTPUT and distclean). Use enable_sim_test in testuite.at, as seen in openbsc: use AT_CHECK() to indicate skipping the test if enable_sim_test isn't 'yes'. Change-Id: I9e8740c7d2dfbd272e22fee85972ef3fda7184a8
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ea688399..ec03c264 100644
--- a/configure.ac
+++ b/configure.ac
@@ -104,15 +104,16 @@ PKG_CHECK_MODULES(TALLOC, [talloc >= 2.0.1])
AC_ARG_ENABLE([pcsc], [AS_HELP_STRING([--disable-pcsc], [Build without PC/SC support])],
[
- enable_pcsc=$enableval
+ ENABLE_PCSC=$enableval
],
[
- enable_pcsc="yes"
+ ENABLE_PCSC="yes"
])
-AS_IF([test "x$enable_pcsc" = "xyes"], [
+AS_IF([test "x$ENABLE_PCSC" = "xyes"], [
PKG_CHECK_MODULES(PCSC, libpcsclite)
])
-AM_CONDITIONAL(ENABLE_PCSC, test "x$enable_pcsc" = "xyes")
+AM_CONDITIONAL(ENABLE_PCSC, test "x$ENABLE_PCSC" = "xyes")
+AC_SUBST(ENABLE_PCSC)
AC_ARG_ENABLE(plugin,
[AS_HELP_STRING(
@@ -231,6 +232,7 @@ AC_OUTPUT(
src/gb/Makefile
src/ctrl/Makefile
tests/Makefile
+ tests/atlocal
utils/Makefile
Doxyfile.core
Doxyfile.gsm