summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVadim Yanitskiy <axilirator@gmail.com>2016-09-23 01:48:59 +0700
committerVadim Yanitskiy <axilirator@gmail.com>2017-03-07 01:06:38 +0700
commit3262f820b5cfb4c76448f605c9804f3e5ca1023d (patch)
tree1d62b0b5a454955e71e6ce91a869d54f1d8df154 /configure.ac
parent68930e85b5945db8ffea055fd178bc1f88b31d99 (diff)
libosmocoding: migrate transcoding routines from OsmoBTS
There are some projects, such as GR-GSM and OsmocomBB, which would benefit from using one shared implementation of GSM 05.03 code. So, this commit introduces a new sub-library called libosmocoding, which (for now) provides GSM, GPRS and EDGE transcoding routines, migrated from OsmoBTS. The original GSM 05.03 code from OsmoBTS was relicensed under GPLv2-or-later with permission of copyright holders (Andreas Eversberg, Alexander Chemeris and Tom Tsou). The following data types are currently supported: - xCCH - PDTCH (CS 1-4 and MCS 1-9) - TCH/FR - TCH/HR - TCH/AFS - RCH/AHS - RACH - SCH Change-Id: I0c3256b87686d878e4e716d12393cad5924fdfa1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 20b5e635..a18197d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,7 @@ case $host in
*)
LTLDFLAGS_OSMOGB='-Wl,--version-script=$(srcdir)/libosmogb.map'
LTLDFLAGS_OSMOGSM='-Wl,--version-script=$(srcdir)/libosmogsm.map'
+ LTLDFLAGS_OSMOCODING='-Wl,--version-script=$(srcdir)/libosmocoding.map'
;;
esac
AC_SUBST(LTLDFLAGS_OSMOGB)
@@ -228,6 +229,7 @@ fi
AC_OUTPUT(
libosmocore.pc
libosmocodec.pc
+ libosmocoding.pc
libosmovty.pc
libosmogsm.pc
libosmogb.pc
@@ -237,6 +239,7 @@ AC_OUTPUT(
src/Makefile
src/vty/Makefile
src/codec/Makefile
+ src/coding/Makefile
src/sim/Makefile
src/gsm/Makefile
src/gb/Makefile
@@ -248,4 +251,5 @@ AC_OUTPUT(
Doxyfile.gsm
Doxyfile.vty
Doxyfile.codec
+ Doxyfile.coding
Makefile)