summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2014-10-26 20:14:04 +0100
committerHarald Welte <laforge@gnumonks.org>2014-10-26 20:14:04 +0100
commita97ebc9599d4b3210d7127a2cc75d552e69eeb9a (patch)
tree60eee24f5b78ad5115b21cb9996406e5cbf4fd3d /Makefile.am
parent42645d7d78a22db7b76039407b7b43bc0cc79c54 (diff)
parent534163badec879a644af985c9f5d04b7c957a355 (diff)
Merge branch 'laforge/sim'
This contains some work from 2012 about creating a general library about the data structure of data contained on SIM cards. This 'libosmosim' is supposed to be used by (among others) * tools to review/modify/personalize SIM card filesystem data * virtual SIM card implementation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index faf7a832..dc9dc371 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,7 @@
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = include src src/vty src/codec src/gsm src/gb src/ctrl tests utils
+AM_CPPFLAGS = $(all_includes) -I$(top_srcdir)/include
+SUBDIRS = include src src/vty src/codec src/gsm src/gb src/ctrl src/sim tests utils
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libosmocore.pc libosmocodec.pc libosmovty.pc libosmogsm.pc \
@@ -49,7 +50,7 @@ install-data-hook:
uninstall-hook:
cd $(DESTDIR)$(htmldir) && rm -rf {core,gsm,vty,codec}
-DX_CLEAN = doc/{core,gsm,vty,codec}/{html,latex}/* doc/html.tar
+DX_CLEAN = doc/{core,gsm,vty,codec}/{html,latex}/* doc/html.tar doc/{core,gsm,vty,codec}/doxygen_sqlite3.db
endif
MOSTLYCLEANFILES = $(DX_CLEAN)