aboutsummaryrefslogtreecommitdiffstats
path: root/pkgs/krops/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/krops/default.nix')
-rw-r--r--pkgs/krops/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/krops/default.nix b/pkgs/krops/default.nix
index e72e94c..2c12015 100644
--- a/pkgs/krops/default.nix
+++ b/pkgs/krops/default.nix
@@ -20,9 +20,9 @@ in
remoteCommand = target: command:
exec "build.${target.host}" rec {
filename = "${openssh}/bin/ssh";
- argv = [
+ argv = lib.flatten [
filename
- "-l" target.user
+ (lib.optionals (target.user != "") ["-l" target.user])
"-p" target.port
"-t"
target.host