aboutsummaryrefslogtreecommitdiffstats
path: root/pkgs/krops/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/krops/default.nix')
-rw-r--r--pkgs/krops/default.nix20
1 files changed, 3 insertions, 17 deletions
diff --git a/pkgs/krops/default.nix b/pkgs/krops/default.nix
index fc52327..d2f9c8a 100644
--- a/pkgs/krops/default.nix
+++ b/pkgs/krops/default.nix
@@ -1,11 +1,5 @@
let
- lib = import ../../lib // {
- isLocalTarget = let
- origin = lib.mkTarget "";
- in target:
- target.host == origin.host &&
- target.user == origin.user;
- };
+ lib = import ../../lib;
in
{ nix, openssh, populate, writeDash, writeJSON }: {
@@ -15,11 +9,7 @@ in
in
writeDash name ''
set -efu
-
- ${populate}/bin/populate \
- ${target'.user}@${target'.host}:${target'.port}${target'.path} \
- < ${writeJSON "${name}-source.json" source}
-
+ ${populate { inherit source; target = target'; }}
${openssh}/bin/ssh \
${target'.user}@${target'.host} -p ${target'.port} \
nixos-rebuild switch -I ${target'.path}
@@ -31,11 +21,7 @@ in
assert lib.isLocalTarget target';
writeDash name ''
set -efu
-
- ${populate}/bin/populate --force \
- ${target'.path} \
- < ${writeJSON "${name}-source.json" source}
-
+ ${populate { inherit source; target = target'; }}
${nix}/bin/nix-build \
-A config.system.build.toplevel \
-I ${target'.path} \