aboutsummaryrefslogtreecommitdiffstats
path: root/lib/types/populate.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/types/populate.nix')
-rw-r--r--lib/types/populate.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/types/populate.nix b/lib/types/populate.nix
index 3b13df0..f35786d 100644
--- a/lib/types/populate.nix
+++ b/lib/types/populate.nix
@@ -56,6 +56,12 @@
};
git = lib.types.submodule {
options = {
+ clean = {
+ exclude = lib.mkOption {
+ default = [];
+ type = lib.types.listOf lib.types.str;
+ };
+ };
ref = lib.mkOption {
type = lib.types.str; # TODO lib.types.git.ref
};