aboutsummaryrefslogtreecommitdiffstats
path: root/lib/types/populate.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/types/populate.nix')
-rw-r--r--lib/types/populate.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/lib/types/populate.nix b/lib/types/populate.nix
index 2cd3267..49996f6 100644
--- a/lib/types/populate.nix
+++ b/lib/types/populate.nix
@@ -11,6 +11,14 @@
else throw "cannot determine type";
type = lib.types.enum known-types;
};
+ derivation = lib.mkOption {
+ apply = x:
+ if lib.types.str.check x
+ then { text = x; }
+ else x;
+ default = null;
+ type = lib.types.nullOr (lib.types.either lib.types.str source-types.derivation);
+ };
file = lib.mkOption {
apply = x:
if lib.types.absolute-pathname.check x
@@ -47,6 +55,13 @@
});
source-types = {
+ derivation = lib.types.submodule {
+ options = {
+ text = lib.mkOption {
+ type = lib.types.str;
+ };
+ };
+ };
file = lib.types.submodule {
options = {
path = lib.mkOption {