aboutsummaryrefslogtreecommitdiffstats
path: root/lib/types/populate.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/types/populate.nix')
-rw-r--r--lib/types/populate.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/lib/types/populate.nix b/lib/types/populate.nix
index 49996f6..bf90ace 100644
--- a/lib/types/populate.nix
+++ b/lib/types/populate.nix
@@ -81,6 +81,10 @@
type = lib.types.listOf lib.types.str;
};
};
+ fetchAlways = lib.mkOption {
+ type = lib.types.bool;
+ default = false;
+ };
ref = lib.mkOption {
type = lib.types.str; # TODO lib.types.git.ref
};