aboutsummaryrefslogtreecommitdiffstats
path: root/pkgs/populate/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2020-02-18 14:34:10 +0100
committerGitHub <noreply@github.com>2020-02-18 14:34:10 +0100
commit8161ec736759a7f21d9d6ec6e5ff8189df9ebbe7 (patch)
tree0a111953df144e407b13c59a5512e87391083931 /pkgs/populate/default.nix
parentf1b7112ac3cbe090e96f2c82c525b6db69b82034 (diff)
parentd51f353cb3ca667957e05699e4f250c9cd4d0882 (diff)
Merge pull request #17 from Mic92/no-writers
use writers from nixpkgs
Diffstat (limited to 'pkgs/populate/default.nix')
-rw-r--r--pkgs/populate/default.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/populate/default.nix b/pkgs/populate/default.nix
index acabc02..736376e 100644
--- a/pkgs/populate/default.nix
+++ b/pkgs/populate/default.nix
@@ -1,7 +1,7 @@
with import ../../lib;
with shell;
-{ coreutils, dash, findutils, git, jq, openssh, pass, rsync, writeDash }:
+{ coreutils, dash, findutils, git, jq, openssh, pass, rsync, writers }:
let
check = { force, target }: let
@@ -145,7 +145,7 @@ let
populate = target: name: source: let
source' = source.${source.type};
target' = target // { path = "${target.path}/${name}"; };
- in writeDash "populate.${target'.host}.${name}" ''
+ in writers.writeDash "populate.${target'.host}.${name}" ''
set -efu
${pop.${source.type} target' source'}
'';
@@ -196,7 +196,7 @@ let
in
{ backup ? false, force ? false, source, target }:
-writeDash "populate.${target.host}" ''
+writers.writeDash "populate.${target.host}" ''
set -efu
${check { inherit force target; }}
set -x