summaryrefslogtreecommitdiffstats
path: root/systems/xu/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'systems/xu/config.nix')
-rw-r--r--systems/xu/config.nix152
1 files changed, 152 insertions, 0 deletions
diff --git a/systems/xu/config.nix b/systems/xu/config.nix
new file mode 100644
index 0000000..761a018
--- /dev/null
+++ b/systems/xu/config.nix
@@ -0,0 +1,152 @@
+{ config, pkgs, ... }: {
+ krebs.build.host = config.krebs.hosts.xu;
+
+ imports = [
+ ../../configs/autotether.nix
+ ../../configs/hw/x220.nix
+ ../../configs/exim-retiolum.nix
+ ../../configs/gitconfig.nix
+ ../../configs/gitrepos.nix
+ ../../configs/mail-client.nix
+ ../../configs/man.nix
+ ../../configs/nginx/public_html.nix
+ ../../configs/ppp.nix
+ ../../configs/pulse.nix
+ ../../configs/retiolum.nix
+ ../../configs/binary-cache
+ ../../configs/br.nix
+ ../../configs/xserver
+ ../../configs/xsessions
+ ../../configs/xserver/xkiller.nix
+ {
+ environment.systemPackages = with pkgs; [
+
+
+ # root
+ cryptsetup
+
+ # tv
+ bc
+ bind # dig
+ brain
+ cac-api
+ dic
+ file
+ gnupg1compat
+ haskellPackages.hledger
+ jq
+ mkpasswd
+ netcat
+ netcup
+ nmap
+ p7zip
+ (pkgs.pass.withExtensions (ext: [
+ ext.pass-otp
+ ]))
+ q
+ qrencode
+ texlive.combined.scheme-full
+ tmux
+
+ #ack
+ #apache-httpd
+ #ascii
+ #emacs
+ #es
+ #esniper
+ #gcc
+ #gptfdisk
+ #graphviz
+ #haskellPackages.cabal2nix
+ #haskellPackages.ghc
+ #haskellPackages.shake
+ #hdparm
+ #i7z
+ #iftop
+ #imagemagick
+ #inotifyTools
+ #iodine
+ #iotop
+ #lshw
+ #lsof
+ #minicom
+ #mtools
+ #ncmpc
+ #nethogs
+ #nix-prefetch-scripts #cvs bug
+ #openssl
+ #openswan
+ #parted
+ #perl
+ #powertop
+ #ppp
+ #proot
+ #pythonPackages.arandr
+ #pythonPackages.youtube-dl
+ #racket
+ #rxvt_unicode-with-plugins
+ #scrot
+ #sec
+ #silver-searcher
+ #sloccount
+ #smartmontools
+ #socat
+ #sshpass
+ #strongswan
+ #sysdig
+ #sysstat
+ #tcpdump
+ #tlsdate
+ #unetbootin
+ #utillinuxCurses
+ #xdotool
+ #xkill
+ #xl2tpd
+ #xsel
+
+ unison
+ ];
+ }
+ ];
+
+ boot.initrd.luks.devices.xuca.device = "/dev/sda2";
+
+ fileSystems = {
+ "/" = {
+ device = "/dev/mapper/xuvga-root";
+ fsType = "btrfs";
+ options = ["defaults" "noatime" "ssd" "compress=lzo"];
+ };
+ "/bku" = {
+ device = "/dev/mapper/xuvga-bku";
+ fsType = "btrfs";
+ options = ["defaults" "noatime" "ssd" "compress=lzo"];
+ };
+ "/home" = {
+ device = "/dev/mapper/xuvga-home";
+ fsType = "btrfs";
+ options = ["defaults" "noatime" "ssd" "compress=lzo"];
+ };
+ "/boot" = {
+ device = "/dev/sda1";
+ };
+ };
+
+ environment.systemPackages = with pkgs; [
+ ethtool
+ tinc_pre
+ iptables
+ #jack2
+
+ gptfdisk
+ ];
+
+ networking.wireless.enable = true;
+
+ #services.bitlbee.enable = true;
+ #services.tor.client.enable = true;
+ #services.tor.enable = true;
+
+ # The NixOS release to be compatible with for stateful data such as databases.
+ system.stateVersion = "15.09";
+}