summaryrefslogtreecommitdiffstats
path: root/pkgs/haskell/xoutinfo.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/haskell/xoutinfo.nix')
-rw-r--r--pkgs/haskell/xoutinfo.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/pkgs/haskell/xoutinfo.nix b/pkgs/haskell/xoutinfo.nix
new file mode 100644
index 0000000..64b6f87
--- /dev/null
+++ b/pkgs/haskell/xoutinfo.nix
@@ -0,0 +1,16 @@
+{ mkDerivation, aeson, base, bytestring, fetchgit, lib, X11 }:
+mkDerivation {
+ pname = "xoutinfo";
+ version = "0.1.0.0";
+ src = fetchgit {
+ url = "https://cgit.ni.krebsco.de/xoutinfo";
+ sha256 = "1g3s9vyy7bpsl2zjiq6kk16c8hhf3n2yz4lv3ic0qy0n6wn6qqi8";
+ rev = "cf7377886a55e36701bd0d5ce7c723aa6d7bd9bd";
+ fetchSubmodules = true;
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [ aeson base bytestring X11 ];
+ license = lib.licenses.wtfpl;
+ mainProgram = "xoutinfo";
+}