summaryrefslogtreecommitdiffstats
path: root/tv/2configs/vim.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-11-01 13:28:16 +0100
committertv <tv@krebsco.de>2015-11-01 13:28:16 +0100
commit9fbb95d510fac7f94fe324891545eed9d5e108b4 (patch)
tree2133b4b6187239ab81287d7b7f6f716f3a13c8dc /tv/2configs/vim.nix
parent7033d7b944668efa806371a172410dbfc3430cdb (diff)
tv base: import vim
Diffstat (limited to 'tv/2configs/vim.nix')
-rw-r--r--tv/2configs/vim.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tv/2configs/vim.nix b/tv/2configs/vim.nix
index 7eb2eb1..74eee0a 100644
--- a/tv/2configs/vim.nix
+++ b/tv/2configs/vim.nix
@@ -7,6 +7,13 @@ let
vim'
];
+ # Nano really is just a stupid name for Vim.
+ # Note: passing just pkgs.vim to cvs to not rebuild it all the time
+ nixpkgs.config.packageOverrides = pkgs: {
+ cvs = pkgs.cvs.override { nano = pkgs.vim; };
+ nano = vim';
+ };
+
environment.variables.EDITOR = mkForce "vim";
};