summaryrefslogtreecommitdiffstats
path: root/tv/2configs/sub/xr.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2015-11-07 19:24:46 +0100
committertv <tv@krebsco.de>2015-11-07 19:24:46 +0100
commit0f8539981b27ca15e7b2aa781cea167cb5204b1d (patch)
tree5d9027ecb3961831959f0fc086861e91909f4836 /tv/2configs/sub/xr.nix
parent6a0685b3b685bdc21624f674c5bd6ba912fecbce (diff)
parentf5e99acb83f469bd302e4c336edfa58320d60fc2 (diff)
Merge remote-tracking branch 'nomic/master'
Diffstat (limited to 'tv/2configs/sub/xr.nix')
-rw-r--r--tv/2configs/sub/xr.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/tv/2configs/sub/xr.nix b/tv/2configs/sub/xr.nix
new file mode 100644
index 0000000..6c9cbb9
--- /dev/null
+++ b/tv/2configs/sub/xr.nix
@@ -0,0 +1,22 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+ krebs.per-user.xr.packages = [
+ pkgs.cr
+ ];
+
+ security.sudo.extraConfig = "tv ALL=(xr) NOPASSWD: ALL";
+
+ users.users.xr = {
+ extraGroups = [
+ "audio"
+ "video"
+ ];
+ group = "subusers";
+ home = "/home/xr";
+ uid = 1660006127; # genid xr
+ useDefaultShell = true;
+ };
+}