summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/default.nix b/default.nix
deleted file mode 100644
index 599a096..0000000
--- a/default.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-
-let
- pkgs = import <nixpkgs> {};
- hsEnv = pkgs.haskellPackages.ghcWithPackages (hsPkgs : with hsPkgs; [
- lens
- mtl
- ]);
-in
-
-pkgs.myEnvFun {
- name = "hack";
- buildInputs = with pkgs; [
- hsEnv
- ];
-
- # XXX https://nixos.org/wiki/Haskell says:
- # Since tools (such as hdevtools [snap-loader-dynamic in our case]) that
- # rely on the ghc-api to do haskell language manipulation are sensitive
- # to nix-wrapping of ghc, we need the extraCmds line to ensure the
- # proper ghc-wrapping environment variables are set inside the
- # dev-environment shell.
- extraCmds = ''
- $(grep export ${hsEnv.outPath}/bin/ghc)
- '';
-}