aboutsummaryrefslogtreecommitdiffstats
path: root/disko.nix
diff options
context:
space:
mode:
Diffstat (limited to 'disko.nix')
-rw-r--r--disko.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/disko.nix b/disko.nix
index 2e6805a..ed385e8 100644
--- a/disko.nix
+++ b/disko.nix
@@ -25,7 +25,7 @@ let
fun.table = q: x: ''
parted -s -a optimal ${q.device} mklabel ${x.format}
- ${concatStrings (imap (i: part: " \nparted -s -a optimal ${q.device} mkpart ${part.part-type} ${part.fs-type or ""} ${part.start} ${part.end} ${optionalString (part.bootable or false) "\nparted -s -a optimal ${q.device} set ${toString i} boot on "}") x.partitions)}
+ ${concatStringsSep "\n" (imap (i: part: "parted -s -a optimal ${q.device} mkpart ${part.part-type} ${part.fs-type or ""} ${part.start} ${part.end} ${optionalString (part.bootable or false) "\nparted -s -a optimal ${q.device} set ${toString i} boot on "}") x.partitions)}
${concatStrings (imap (i: x: f (q // { device = q.device + toString i; }) x.content) x.partitions)}
'';